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CodeWarrior Development Studio
for Freescale S12(X) Microcontrollers Quick Start

This Quick Start explains how to install the CodeWarrior Development 
Studio for S12(X) V5.1 software and then create, build, and debug a 
project using the IDE.

NOTE In this document, numbered steps are for advanced users. 
Lettered steps are the expanded descriptions.

1. Install the CodeWarrior software from CD.

a. Insert the CodeWarrior Development Studio installation CD into the 
CD-ROM drive — Auto Install begins.

NOTE If Auto Install does not start, run the Setup.exe located in the 
root directory of the CD. 
The CodeWarrior software may be part of a DVD included with 

SYSTEM REQUIREMENTS

Hardware PC with 1 GHz Intel® Pentum®-compatible 
processor 
512 MB of RAM (1 GB recommended)
CD-ROM drive
Depending on host-target connection: Parallel 
Port, 9-pin Serial Port, or USB Port

Operating System Microsoft® Windows® XP 32-bit and 64-bit 
(Professional Edition)

Microsoft Windows Vista® Business 32-bit
Microsoft Windows Vista Home Premium 32-bit
Microsoft Windows Vista Business 64-bit
Microsoft Windows 7 32-bit and 64-bit (Home 
Premium and Professional Edition)

Disk Space 2 GB total
400MB on Windows system disk

Section A: Installing Software
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your kit. In this case, click Install CodeWarrior Development 
Studio for S12(X) V5.1, follow the on-screen instructions, and 
skip to step "Check for updates".

NOTE Special Edition: The Special Edition license is automatically 
installed with your product and you do not need to register it. 
This license allows you to develop projects with  unlimited 
assembly code, up to 32KB of C code for S12(X)derivatives 
and up to 512 bytes of C code for XGATE derivatives.

NOTE Evaluation Edition: The Evaluation license is automatically 
installed with your product and you do not need to register it. 
This license allows you to develop projects as Professional 
Edition within the 30-day evaluation period. After 30 days, the 
license works as Special Edition license (free permanent, but 
feature limited) which supports unlimited assembly code, up to 
32KB of C code for S12(X) derivatives and up to 512 bytes of C 
Code for XGATE derivatives. 

b. Click Launch the installer — the Install wizard appears.

c. Click Next — the License Agreement page appears.

d. Select the I accept the terms in the license agreement option button.

e. Continue clicking Next to step through wizard pages, accepting default 
settings — the Ready to Install the Program page appears.

f. Click Install — At the end of installation, a page appears announcing 
installation is complete.

g. Select the Yes, check for program updates (Recommended) after 
setup complete checkbox to check for updates.

2. Check for updates.

NOTE If the updater already has internet connection settings, you 
may proceed directly to sub-step f.

a. Click Settings in the CodeWarrior Updater dialog box — the 
CodeWarrior Updater Settings dialog box appears.

b. Click Settings — the Connections page of Internet Properties dialog 
box appears.

c. Modify settings, as appropriate, to successfully connect to internet.
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d. Click OK — the Internet Properties dialog box closes.

e. Select an item in the Update Check Scheduling list box and click OK; or 
click Cancel.

f. Click Next.

g. If necessary, enter the username and password.

h. If updates are available, follow the on-screen instructions to download the 
updates to your computer.

NOTE If no updates are found, the software application will display an 
appropriate message. 

i. Click Finish — the installation completes and the CodeWarrior Updater 
dialog box closes.

NOTE For licensing and activation of your CodeWarrior Development 
Studio for Freescale S12(X) Microcontrollers, refer to the 
CodeWarrior Development Suite Quick Start. Save the license 
file, license.dat to the installation root folder, the default is 
C:\Program Files\Freescale\CWS12v5.1.

1. Create a new project.

a. Select Start > Programs > Freescale CodeWarrior > CodeWarrior 
Development Studio for S12(X) V5.1 > CodeWarrior IDE — the IDE 
starts and the Startup dialog box appears.

Section B: Creating and Building an S12(X) Project
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Startup Dialog Box

b. Click Create New Project — the Device and Connection page appears.

NOTE This section of the quick start demonstrates using the New 
Project Wizard. We use an MC68HC912DG128 target as an 
example.

c. Expand HC12 and Automotive Family and select the 
MC68HC912DG128 derivative.

Device and Connection Page

d. Select Full Chip Simulation as your default connection.

e. Click Next — the Project Parameters page appears.
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Project Parameters Page

f. In the Project name text box, type a project name of your choice.

NOTE The IDE automatically creates a folder with the same name in 
specified location. The IDE automatically adds .mcp extension 
when it creates project.

g. In the Location text box enter location to store the project. 

h. Select the C checkbox as language to be supported by the project.

NOTE You can select Finish to accept defaults for remaining options.

i. Click Next — the Add Additional Files page appears.

This page allows you to browse folders and add or remove files to or from 
the project.
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Add Additional Files Page

j. Click Next — the C/C++ Options page appears.

C/C++ Options Page

k. Select the ANSI startup code option button as level of startup code to 
use.

l. Select the Small as memory model option button as memory model to 
use.

m. Select the None option button for floating point format to support.

n. Click Next — the PC-Lint page appears.
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PC-Lint Page

o. Select the No option button.

p. Click Finish — the IDE creates a project according to your specifications; 
the Project window appears, docked at left side of main window.

NOTE To undock project window, double-click the double gray lines. 
To re-dock window, right click in title tab and select Docked.

Project Window
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2. Select a connection.

a. To change the derivative and connection, click the Change MCU/

Connection  icon.

b. Select the desired connection from the list.

3. Edit the source code

a. Double click main.c in the Sources folder – the Editor window opens 
displaying contents of file.

main.c in Editor Window

b. Make changes to the contents of main.c file, if desired. 

c. If you make changes to the main.c file, from IDE main menu bar, select 
File > Save – IDE saves the changes.

4. Add files, if required.

a. In the project window, select a folder.

b. From the IDE main menu bar, select Project.

c. Select Add Files — the Select files to add dialog box appears.

d. Navigate to the directory that contains file you want to add.

e. Select filename of the file you want to add to the project.

f. Click Open — Project messages appear indicating access path has been 
added to target, if path is new to the project.

g. In the project window, filename of the added file appears under the 
selected folder.
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5. Build the project.

a. From the IDE main menu bar, select Project.

b. Select Make — the IDE builds (assembles, compiles, and links) project; 
the Error & Warnings window opens showing any error messages and 
warning messages.

1. Start the debugger.

a. Click on the project window title bar to activate the project window.

b. From the main menu bar, select Project > Debug — the True-Time 
Simulator & Real-Time Debugger window appears.

True-Time Simulator & Real-Time Debugger Window

NOTE The Source and Assembly panes display main.c program 
and code.

2. Set breakpoints.

a. Point at a C statement in the Source window and right-click — Source 
context menu appears.

b. Select Set Breakpoint — Permanent breakpoint mark is set.

Section C: Debugging an S12(X) Project
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3. Run the project.

a. From the main menu of the True-Time Simulator & Real-Time 
Debugger window, select Run — Run menu appears.

b. Select Start/Continue or click on Start/Continue icon  — the 
program executes till the first breakpoint and the Command pane 
displays the program status.

Command Pane

4. Click the Start/Continue icon  — the simulator resumes execution.

5. Click the Halt icon  — the simulator stops program execution.

6. From the Debugger Simulator window toolbar, select File > Exit to 
exit the debugger.

7. From the IDE main window toolbar, select File > Exit to exit the 
CodeWarrior IDE.

1. Create a new project.

a. Select Start > Programs > Freescale CodeWarrior > CodeWarrior 
Development Studio for S12(X) V5.1 > CodeWarrior IDE — the IDE 
starts and the Startup dialog box appears.

Section D: Creating and Building an S12(X) Project with 
XGATE Support
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Startup Dialog Box

b. Click Create New Project — the Device and Connection page appears.

NOTE This section of the quick start demonstrates using the New 
Project Wizard. We use an MC9S12XDP512 target as an 
example.

c. Expand HCS12X and HCS12XD Family and select the MC9S12XDP512 
derivative.

Device and Connection Page

d. Click Next — the XGATE Setup page appears.

e. Select the Multi Core (HCS12X and XGATE) option button.
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XGATE Setup Page

f. Click Next — the Project Parameters page appears.

Project Parameters Page

NOTE The IDE automatically creates a folder with the same name in 
specified location. The IDE automatically adds .mcp extension 
when it creates project.

g. In the Location text box enter location to store the project.

h. Select the C checkbox as language to be supported by the project.

NOTE You can select Finish button to accept defaults for remaining 
options.
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i. Click Next — the Add Additional Files page appears.

This page allows you to browse folders and add or remove files to or from 
the project.

Add Additional Files Page

j. Click Next — the C/C++ Options page appears.

C/C++ Options Page

k. Select the ANSI startup code option button as level of startup code to 
use.

l. Select the Banked option button as memory model to use.

m. Select the None option button for floating point format to support.

n. Click Next — the Memory model options page appears.

o. Select FLASH from the Memory Mapping option buttons.
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Memory Model Options Page

p. Click Next — the XGATE Options page appears.

q. Select None from the Select the XGATE Floating point support option 
buttons.

r. Select XGATE in RAM from the Select which memory will be used to 
store XGATE code option buttons.

XGATE Options Page

s. Click Next — the PC-Lint page appears.
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PC-Lint Page

t. Select No from the Do you want to create a project set up for PC-
lint(TM) option buttons.

u. Click Finish — the IDE creates a project according to your specifications; 
the project window appears, docked at left side of main window.

NOTE To undock project window, double-click the double gray lines. 
To re-dock window, right click in title tab and select Docked.

Project Window
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NOTE To undock Project window, double-click docking handle 
(double gray lines at top of window). To re-dock window, right 
click in title bar of Project Window, and select Docked.

2. Select a connection.
For this example, we specified Full Chip Simulation (FCS).

a. To change the derivative and connection, click Change MCU/

Connection icon .

b. Select the desired connection from the list.

3. Edit the source code.

a. Double click main.c in the Sources folder – the Editor window opens 
displaying contents of file.

b. Make changes to the contents of main.c file, if desired 

c. If you make changes to the file, from IDE main menu bar, select File > 
Save – IDE saves the changes.

main.c in Editor Window

4. Add files, if required.

a. In the project window, select a folder.

b. From the IDE main menu bar, select Project.

c. Select Add Files — the Select files to add dialog box appears.

d. Navigate to the directory that contains file you want to add.

e. Select filename of the file you want to add to project.
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f. Click Open — Project messages appear indicating access path has been 
added to target, if path is new to the project.

g. In the project window, filename of the added file appears under the 
selected folder.

5. Build the project.

a. From the IDE main menu bar, select Project.

b. Select Make — the IDE builds (assembles, compiles, and links) project; 
the Error & Warnings window opens showing any error messages and 
warning messages.

1. Start the debugger.

a. Click on the project window title bar to activate the project window.

b. From the main menu bar, select Project > Debug — the True-Time 
Simulator & Real-Time Debugger window appears.

True-Time Simulator & Real-Time Debugger Window

NOTE The Source and Assembly panes display main.c program 
and code. The left set of windows displays the state of 
HCS12X core and the right set displays the state of XGATE 
core.

Section E: Debugging an S12(X) Project with XGATE 
Support
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2. Run project

a. From the main menu of the True-Time Simulator & Real-Time 
Debugger window, select Run — Run menu appears.

b. Select Start/Continue or click on Start/Continue icon  — the 
program executes till the first breakpoint and the Command pane 
displays the program status.

Command Pane

3. Click the Start/Continue icon  — the simulator resumes execution.

4. Click the Halt icon  — the simulator stops program execution.

5. From the Debugger Simulator window toolbar, select File > Exit to 
exit the debugger.

6. From the IDE main window toolbar, select File > Exit to exit the 
CodeWarrior IDE.

Congratulations!
You have successfully created, built, and debugged an S12(X) 
project and an S12(X) project with XGATE Support using the 
CodeWarrior Development Studio for S12(X) V5.1 software!
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How to Contact Us

Corporate 
Headquarters

Freescale Semiconductor, Inc.
6501 William Cannon Drive West
Austin, Texas 78735
U.S.A.

World Wide Web http://www.freescale.com/codewarrior

Technical Support http://www.freescale.com/support

Revised: August 11, 2010
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http://www.freescale.com/support
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